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1 Introduction  

1.1 Background  
The Contract Preparation Form software support tool (CPF Editor) provides the basis for 
editing information during FP6 contract negotiations and the input data for preparing the final 
contract. This information must be complete, consistent with the negotiations and correct. It is 
the responsibility of the contractor to check the information and ensure it is up to date and 
accurate. Any problems with the data may lead to delays in concluding the contract.  
 
 
Any questions regarding the negotiation process will be answered by the Project Officer 
assigned to the Project.  

1.2 Purpose 
The CPF Editor combines a template document with existing data to produce an editable data 
file. This makes it simple to update the necessary information for the contract. The templates 
contain all the fields that are used for contractual and statistical purposes. The application can 
be used to validate that all the necessary information has been provided.  

1.3 Scope of the Document 
 
This document covers the features of the CPF Editor (version 2.8) user interface and the basic 
functions that allow the data to be checked, edited and then printed. Key points to remember 
are shown using the symbol 2.  
 
For each FP6 contract Instrument, Integrated Projects, Networks of Excellence etc, the details 
required will vary and so the detailed content of the individual fields is not covered by this 
document. 
 

2 The detail of the individual fields is defined in the Guide for Contract Preparation 
covering the relevant instrument.  

 
The CPF Editor covers only the administrative data of the contract. The Project Technical 
Annex has still to be prepared along with other necessary documents.  
 
There is some information relating to the negotiations that are included in the contract but are 
not included in the CPF Editor, such as special conditions. These will be dealt with by the 
Project Officer.  
 

1.4 Reference Documents 
Details of the individual fields in the Contract Preparation Forms can be found in the 
document Guidelines for Contract Preparation.  
 

2 All important documents can be found on CORDIS 
 
http://www.cordis.lu/fp6/find-doc.htm 
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The CPF Editor uses data from the Proposal submission or other available data as a starting 
point and so the original Proposal Documents can be used for reference.  

1.5 Configuration Required 
 
The CPF Editor is a Window's application and runs on Windows NT, Windows 98/Me, 
Windows 2000 and Windows XP. The minimum specification for the PC is either a Pentium 
II PC with 64Mb Memory or the minimum recommended specification of the operating 
system. The CPF Editor data file uses XML format. 

2 Distributing files and file naming convention 
 

2.1 The Application 
 
The CPF Editor application can be downloaded from the CORDIS Site on the internet.  
 
www.cordis.lu/fp6/contractpreparation 
 
Follow the link on the web page to the electronic submission tool for CPF. This gives 
information on how to download the files from the internet. 
 
The application is compressed into a single file (winzip format) and the files must be 
extracted to use the application. The CPF Editor has a number of files necessary to function 
properly. These are:- 
 

Cpfeditor.exe The cpfeditor main executable file  
Cpfeditor.ini Configuration details.  
*.pbd Necessary support files  
*.dll Application extension files 
*.scc Necessary files 
LOVs\*.lov List Of Values files. Contain text  
  

 
There are a number of files with the extension *.LOV These provide a list of values 
associated with one or more fields in the Contract Preparation Forms. 
 

2.2 Version of the software application 
The version of the software can be found by selecting the Help Menu About Option. This will 
display the following dialog box containing the version number information.  
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2.3 The Data File  
After the Commission decision confirming the contract can be negotiated, the Commission 
will send a copy of the CPF data file and this document to the co-ordinating partner for 
distribution to the participants. The data file contains information about the project submitted 
at the proposal stage and should be stored in the same directory as the CPF Editor application 
files.  
 
The co-ordinating partner is responsible for distributing the data file to all the contractors and 
it is up to each contractor to keep the information relevant to themselves up to date and 
accurate. 
 
The contractors should use the file naming convention proposed by the Commission to assist 
in the correct handling of the CPF data file.  
 

2.4 Basic file management  
The co-ordinating partner should check that the file name of the data (.cpf) file has the right 
information for the Project to be negotiated. The Commission is using a naming convention 
and so it should be possible to identify that the file that has been received is the correct one 
for the Project. The structure of the file name is as follows. 
 

(Programme)-(CallID)-(ProposalID)-(InstrumentID)-nn.CPF 
 
Where: 

Programme -is the programme under which the contract is negotiated 
 

CallID   -identifies the call under which the contract is negotiated 
 

ProposalID -is a unique identifier  
 

InstrumentID -identifies the instrument relating to the contract. 
 

nn -is a two digit number used by participants for identifying file. 2 It is 
omitted in the file sent by the Commission 

 
2 If the Programme, Call, Proposal, and Instrument details in the file name are not the 
ones for your project then contact your Project Officer.  

 
The co-ordinating partner must forward copies of the CPF Editor, the original CPF data file 
and the support files to all participant organisations in the project.  
 
It is recommended that each participant create a separate working area on a PC for the files 
relating to contract negotiations and that the CPF Editor application, the associated data file 
and the support files are stored in it.  
 
You should use a working copy of the file for updating and make sure that an original is 
stored elsewhere (see section 6.2 Preparation) 
 
Any participant may introduce additional or alternative file management, or version control 
measures, in line with in house procedures, if appropriate. For the Commission the important 
thing is that the final version is up to date and has the original filename. 
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3 Opening the CPF Editor  
 

3.1 Introduction  
All partners will need to open the CPF data file and view the data in it. The CPF Editor is a 
standard software application and can be run by double clicking on the icon in NT Explorer or 
Windows Explorer, after installation.  
 
When the file is first opened the user interface contains no data and this has to be loaded to 
start editing.  

 
The user interface is simple and straightforward, with the main functionality available from 
both the main menu bar and a simple icon toolbar.  
 

The working copy of the CPF data file can be opened using the standard file open Icon  
on the toolbar or using the File Menu Item Open. This will display a standard file open 
dialogue box which uses Contract Preparation Forms (*.CPF) file type. Browse for the data 
file where it was stored and open it. The data will be loaded into the main window for viewing 
and editing.  
 
The following diagram and table provide notes on the user interface of an open CPF Editor 
data file.  
 

Header 
Main Menu  
Toolbar 
 
Main 
Window 



 

 

The basic user interface of the CPF Editor with a data file open  

 



 

 

 

Main features of the User Interface table  
 
The table summarises the main features of the user interface.  
 
Feature Type  Purpose Notes 
Header Window Header Identifies the file name of the currently open CPF data 

file. 
H:\FP6_CPF_Editor\ ……. in the diagram. 
Useful reference for filename.  

Layout 
 

Heading  Section Header The layout section displays the available forms for the instrument.  

<<An>> CPF link to form An,  To provide access to each form. 
 

When selected changes display windows to display form An, where n is the form number n 

Participants 
 

Heading  Section Header A consortium can be made up of one or more participants. This section allows the user to 
navigate through the participant information, view it and edit it.  

Add 
 

Button Adds a set of participant forms to the CPF Edit Function – Only available when participant forms A2a are displayed 

Delete 
 

Button Deletes the currently selected set of participant forms to 
the CPF 

Edit Function – Only available when participant forms A2a are displayed 

Prior 
 

Button Navigation Function Goes to the previous set of participant forms 

Next 
 

Button Navigation Function  Goes to the next set of participant forms 

X of Y Message Indicates the participant number of the currently 
displayed participant details 

Only displayed when participant forms are displayed. X is the number of the participant and Y 
the number of participants in the consortium.  

Main Display 
 

Window Displays all forms associated with the contract 
instrument.  

CPF Forms are displayed and can be edited in this area. The form A2a is displayed in the 
example.  

Legend  
 

Heading Section Head The legend is for the description of the different types of field in the main display. The content 
will vary from page to page and instrument to instrument.  

Mandatory Note Colour code (yellow) indicates mandatory field in the 
display area 

The consortium must complete any mandatory fields, otherwise it will not be possible to 
produce the contract.  

Protected  Note Colour code (blue) indicates protected  field in the 
display area 

A protected field cannot be edit by the consortium and contains essential proposal information.  

Optional Note  Colour code (white) indicates optional field in the display 
area 

These fields are optional.  

Page Validation  Button  To check to ensure that the data is entered. 
 

See procedure on validation of the data.  
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3.2 Saving Data 
 
If any changes are made to the data file then  save the updated file using the icon . 
This will overwrite the working copy of the data file. 
 
It is important to note that if the participant changes information then it is necessary to 
save the working copy to a unique copy per participant for collating by the co-
ordinating partner (see Collation).  
 
The recommended method for uniquely identifying a participant’s version of the cpf 
data file is to use the optional two digit number allocated in the file naming convention. 
Therefore the file name for a copy of the working document being edited by the co-
ordinating partner to update their participant information will be  
 
(Programme)-(CallID)-(ProposalID)-(InstrumentID)-01.CPF 
 
Select the icon  or the File Menu item Save as. The simplest method is to save each 
file name using the optional nn number identified in the file naming convention. For 
example, the file for participant number 3 will be named: 
 
(Programme)-(CallID)-(ProposalID)-(InstrumentID)-03.CPF 
 
 

3.3 Closing the data file and exiting the CPF Editor 
 
To close the cpf data file without exiting the application select the File Menu Item 
‘Close’. To exit the CPF Editor select the icon from the toolbar  or the File Menu 
Item ‘Exit’. 
 
2 No warning is given reminding you to save data when closing or exiting and so 
please remember to save the data frequently. 
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4 Checking and Editing the Data  
 

4.1 Introduction  
 
There are several reasons why the information in the CPF Editor is incomplete or 
inaccurate. The data is a subset of the information supplied at the time the proposal was 
submitted and information can change over time. Where appropriate some 
organisational data may be added from other Commission databases on the participant 
organisation.  
 
The table gives some possible scenario’s that might lead to inaccurate data and the 
impact it will have on the information in the data set.  
 
Situation  Consequences  

The company has issued a new set of annual 
financial documents (e.g. balance sheet) 

Financial data for the participant need to be updated 

The original contact person has left the 
company or moved offices.  

Contact person needs to be deleted, added or 
modified  

The company has been taken over, merged or 
its head office has moved. 

Participant details will have changed and also 
possibly banking arrangements.  

The Evaluation of the proposal recommended 
certain changes in the Project budget  

Budget distribution of all the partners. 

The Commission has requested certain changes 
to the proposal 

Most likely to effect the Technical annex but may 
impact on one or more CPF (project duration) 

Additional information is required for the 
contract that is not required for the proposal  

For example, additional financial information 

 
2It is therefore important to verify all the data in the CPF data File.  

 
The Guidelines for Contract Preparations contains information on the content of the 
individual CPF forms and should be used as references for the requirements of any 
individual fields. 
 

4.2 Completeness Check the Business Rules Report  
 
The CPF Editor does support basic checking for completeness by providing a function 
to give information on whether the mandatory and protected content of the forms is 
included or not. If the Business Rules Report shows that a field should be completed but 
you feel that, in your particular case, it is not relevant then contact your Project Officer 
for advice.  
 
The following dialog box and table provide the information in relation to the business 
rules. 
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Business Rules Report 
 

Business Rules Report table of features 
Feature Type  Purpose Notes 
Business 
Rules Report 

Header Heading Displays the results of Business Rules test. 

<<Page>> Header Indicates page 
on a form 

The text associated with the header identifies the page for which the 
rule applies. 

<<Field>> [number] Indicates 
partner number 

The number in [] is associated with the partner (participant number) 
for which the rule applies. 

<<Field>> Header Indicates field 
on a form 

The text associated with the header identifies the field for which the 
rule applies. 

<<Rule>> Header Indicates type of 
field on a form 

Only mandatory and protected fields have rules associated with them. 
If there is a number [n] displayed it is the participant number.  

Status  icon  Section Header The green icon  indicates that the field has complied with 
the rule. The red icon  that it has not.  

 
 

Checkbox Selection of 
participants 

When selected the participant information will be printed for Entire 
CPF and Participant Information options 

Prior 
 

Button displays the 
previous page  

This button does not work if page validation has been used to display 
the information in the display area. 

Next 
 

Button Goes to the next 
page  

This button does not work if page validation has been used to display 
the information in the display area. 

Print 
 

Button Prints page Prints the displayed contents based on the filter. There is no print 
dialog box.  

Close 
 

Button Close the dialog 
box 

Closes the dialog box.  

Filter Header   
Both Radio 

button 
Indicator Displays both passed and not passed fields. It is recommended that 

this default setting is used for participant data in large consortiums. 
Only passed Radio 

button 
Indicator Displays only fields that have the status indicated by the green 

icon , sorted by field name not participant number.  
Only not 
passed  

Radio 
button 

Indicator Displays only fields that have the status indicated by the red 
icon , sorted by field name not participant number.. 
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There are two levels of checking, page validation and file validation. The page 
validation button will provide information on the current page. The icon  and the 
Options menu item ‘ Check business rules’ will provide information on the entire file.  
 

2It is recommended for large consortiums, the default setting when the windows 
is opened of ‘both’ is used for participant data because the data is sorted by 
participant number. The other filter options sort the information by field name.  

 
There are some fields, mainly relating to details of the organisation that are not included 
in the data and must be completed. This is because they were not provided in the 
original proposal or not included in the evaluation data set. The missing information can 
vary with the different instruments and for different organisations but some of the main 
fields are summarised in the table.  
 
Information Type Possible missing data.  
General Project Information Keywords  

 
Participant Information Size of organisation (various fields) 

Number of researchers (number of researcher ) 
Contact Information Administrative details (various fields) 

 
Budget Information  None  

 
Banking Information  
 

All  

Financial Data All (Project Officer to advise) 
 

 

4.3 Non CPF data 
 
During contract negotiations there is some information that is not recorded in the CPF 
Editor. This mainly relates to special conditions in the contract and some internal 
administrative information. This will be dealt with by the Project Officer in generating 
the contract.  

4.4 Correctness Check  
 
The responsibility for checking data depends on the type of data. The co-ordinating 
partner should be responsible for project information and co-ordinator partner banking 
information while the individual participant should edit their own information, both 
legal and financial. This includes the budget allocation for the contractor in the budget 
estimate table.  
 
Information Type Responsibility 
General Project Information Co-ordinating partner  
Participant Information Participant  
Contact Information Participant 
Partner Financial Data Participant 
Budget Information  Participant  
Banking Information  Co-ordinating partner 
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4.5 Editing Information  
 
When editing the data there is a simple rule to be followed: - 
 

If you are editing participant information, including participant budget data, 
you should do the changes in the file that has the participant number in the file 
name. The co-ordinating partner will have the number 01.  
 
If you are editing project or banking information then the co-ordinating party 
should use the working copy with no participant number  
 

It is not necessary to correct the information in the CPF immediately, some information 
is not included and other information may be subject to further negotiation, such as 
adjustment to the budgets. However, editing the data is straightforward for the 
mandatory and optional fields. Simply type any new or modified information into the 
relevant data field, or select the required item from the list box.  
 
2 Only the Co-ordinating partner should change the project information.  
 

4.6 Comparing Information  
 
There is a further check available on the edited data by comparing the edited working 
copy of the file with the original using a comparison tool included in the CPF Editor. 
This check is optional.  
 
To make the comparison, the working copy of the CPF data file is opened using the 

standard file open Icon  or using the File Menu Item Open.  
 
Select the Options Menu Item ‘Compare file’ or select the icon . This will display a 
standard file open dialog box. Browse for the original version of the cpf data file and 
open that. 
 
A comparison window is opened. Where changes have been made the fields will 
provide the relevant information on the change (information removed, modified or 
added). Check that the changes are in line with what was expected as a result of editing 
the file. 
 
The details of the Compare Window are given in the diagram and the table. 



 

 

Diagram of the Compare Window. 
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Table of the main features of the Compare Window 
Feature Type  Purpose Notes 
Header Window 

Header 
Identifies the window as a 
comparison 

 
  

Layout 
 

Heading  Section Header  

<<An>> CPF link to 
form An,  

Select to display form An  When selected changes display windows to display 
form An, where n is the form number 

Navigation 
 

Heading  Section Header .  

Prior 
 

Button Goes to the next page  Navigation Function  

Next 
 

Button Goes to the previous page Navigation Function 

Legend  Heading  
 

 

Removed Note Information  Colour code (red) indicates mandatory field in the 
display area 

Added Note Information Colour code (green) indicates mandatory field in 
the display area 

Modified  Note Information Colour code (purple) indicates mandatory field in 
the display area 

Equal Note Information Colour code (white) indicates mandatory field in 
the display area 

Close Button  Close the window  
 

 

5 Printing Information  
 
To print the Contract Preparation Forms select the File Menu Item Print or click on the icon  
 
This will display a print dialog box with a number of options. Select the radio button option 
and select the Print button.  
 
The Print dialog Box for the CPF Editor 
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The print dialog box contains a number of useful printing options based on a general set of 
Print options and individual options for participants and pages. Data can be printed for the 
project as a whole or by participant. The printing options are summarised in the table. The 
layout of the Print CPF dialog box is given in the diagram. 
 

Print CPF dialogue box table of controls and options  
 
Feature Type  Purpose Notes 
Print Options Heading  Section Header  
 Entire  Radio 

Button 
Prints All CPF’s Prints all forms unless forms are deselected in the other 

sections  
 Participant 
 Information 

Radio 
Button 

Prints only participant 
information 

Select require participants from Participants list for 
printing.  

 Project 
 Level Forms  

Radio 
Button 

Prints project only 
information  

Will only print out only some of the project level forms, 
for example, co-ordinators banking details. 

Select Participants Heading  Section Header Displays all of the participants in the project.  

 Sel 
 

Checkbox Selection of participants When selected the participant information will be printed 
for Entire CPF and Participant Information options 

 Number  
 

Number  Gives the participant 
number  

Edit Function. Delete - Only available when participant 
forms are displayed 

 Short Name  
 

Text Displays shortname of the 
participant 

Displays the short name given in form A2a for the 
contractor.  

Select Pages 
 

Heading  Goes to the previous set 
of participant forms  

When selected the participant information will be printed 
for Entire CPF and Participant Information options 

 Sel  Checkbox Indicates pages to be 
printed 

 

 Page Name  
 

Window Displays Form A1-A4 Displays the page name (A1-A4) given in the layout 
section. 
Pages vary with the different instruments. 

Print  Button  Prints the selected 
information  

 

Cancel Button  Cancels printing 
 

 

 

5.1 Co-ordinator Banking Details  
 
The co-ordinator banking details should be printed as soon as the information is complete and 
correct as the form must be signed by the bank and returned to the Commission.  

6 Collating the Data for Submission  
 

6.1 Introduction  
 
All participants must check the information in the CPF Editor data file. This is to ensure that 
the information relevant to them is up to date and correct. However, the correct data is then 
contained in a number of files each with the different participant details. 
 
The CPF Editor allows the participant information to be collated centrally by the co-
ordinating partner. This is why the naming convention for each participant data is required as 
it allows effective discrimination of participant information while it is collated.  
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6.2 Preparation 
 
All the participant data files should be returned to the co-ordinating partner for collation 
towards the end of negotiations or provide the co-ordinating partner with a note confirming 
that the original data is correct. Either way all participants must take responsibility of the 
correctness of their own data and where necessary provide printed and signed documents to 
the co-ordinating partner. 
 
The result is that the co-ordinating partner should have the files such that the details of the all 
of the participants 1 to n are available to the co-ordinator.  
 
 
(Programme)-(CallID)-(ProposalID)-(InstrumentID).CPF   Working Copy  
(Programme)-(CallID)-(ProposalID)-(InstrumentID)-01.CPF  Co-ordinator 
(Programme)-(CallID)-(ProposalID)-(InstrumentID)-02.CPF  Participant 2 

. 

. 
(Programme)-(CallID)-(ProposalID)-(InstrumentID)-nn.CPF   Participant nn 
 
 
The co-ordinator will have two files, the working copy and its information as participant 1. 
This allows the participant information to be edited separately from the project information, if 
required.  
 

6.3 Consolidation 
 
Files are consolidated by importing the participant information, one participant at a time. 
 
To import files, the working copy of the CPF data file is opened using the standard file open 

Icon  or using the File Menu Item Open.  
 
Select the Options Menu Item ‘Import participant data’ or select the icon. . This will 
display a standard file open dialog box. Browse for the participant cpf data file required and 
open that. Select (Sel) the participant details to be imported and select the button Import. This 
will overwrite the imported participant data.  
 
Note: Due to a temporary problem with the CPF Editor, you should import the data of all the 
different participants starting from the lower participant number until the highest one. 
Otherwise, there will be a problem with the order of the participants. 
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Import Participants dialog box  
 

Table of features of the Import Participant dialog box 
 
Feature Type  Purpose Notes 
Import Participant Heading  Section Header  
 Sel 
 

Checkbox Selection of participants When selected the participant information will be printed for 
Entire CPF and Participant Information options 

 Number  
 

Number  Gives the participant 
number  

Edit Function. Delete - Only available when Form A2a is 
displayed 

 Short 
Name  
 

Text Displays shortname of 
the participant 

Displays the short name given in form A2a for the contractor.  

Import  Button  Imports the selected 
participant  

 

closes Button  Closes the dialog box 
 

 

 
 
2 It is essential that only one set of participant data is selected for each cpf data file otherwise 
the original data will be overwritten.  
 

6.4 Final checks 
 
If more than one partner is selected in an import participants dialog box then it will overwrite 
the data for the participants and the information will be incorrect. To ensure that the final data 
is complete the co-ordinating partner should do a final completeness check on the data.  
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Also, by comparing the final version of the working copy with the original it is possible to do 
some quick checks on the data. If the comparison indicates no changes between the original 
and the final working copy when changes have been made on the original data, then there is a 
problem 
 
If there were no changes to the participant information during negotiations then the fields 
should all be equal.  

7 Return the file to the Commission 
 

7.1 Introduction 
The final copy of the file with the name (Programme)-(CallID)-(ProposalID)-
(InstrumentID).CPF, no participant numbers, should be returned to the Commission as soon 
as the information is thought to be correct, even if the negotiations have not been concluded. 
This is because the Commission prior to contract being generated will carry out certain checks 
and the earliest this data is available for these checks the better. 
 

7.2 Signature 
 
Where signatures are required to documents these should be printed out and signed by the 
relevant authorised authority.  

8 Old files 
If old CPF files (saved with version 1.5 or version 2.0) are open with the latest version of CPF 
Editor (e.g. 2.8), the Editor will specify that those files are from on old format and it will 
convert them to the new version. 

9 Help 

9.1 Getting Help  
The first contact on any issues relating to the negotiations should be with the Project Officer. 
However, technical questions about the CPF Editor can be addressed to the following e-mail 
address.  
 
EC-FP6-IT-HELPDESK@cec.eu.int 
 

9.2 Troubleshooting 
 
Below are a list of possible problems and how to solve them. 
 


